3/06/2017

OpenStack deployment Solaris 11.3 - Part 3/4

Posted in , , , , , ,   with  No comments     Edit
Now I will try to used a supported server for the kernel zone, in my case a T4-1 server (part of the T4 series, described as a supported platform)

root@t4-1:~$ prtdiag -v | grep System
System Configuration:  Oracle Corporation  sun4v SPARC T4-1
Sun System Firmware 8.9.5.a 2016/08/09 15:24

We can confirm also that kernel zones are supported

root@t4-1:~$ virtinfo
NAME            CLASS
logical-domain  current
non-global-zone supported
kernel-zone     supported
logical-domain  supported

Virtual CPU'S: 64

root@t4-1:~$ psrinfo | wc -l
      64

root@t4-1:~$ prtdiag -v | grep Memory
Memory size: 65024 Megabytes

root@t4-1:~$ more /etc/release
                            Oracle Solaris 11.3 SPARC
  Copyright (c) 1983, 2016, Oracle and/or its affiliates.  All rights reserved.
                            Assembled 03 August 2016
root@t4-1:~$

root@t4-1:~# zoneadm list -cv
  ID NAME             STATUS      PATH                         BRAND      IP
   0 global           running     /                            solaris    shared

I will create a kernel zone and will assign more memory and vcpus (will try to give enough resource for vm/zones creation), following oracle documentation

https://docs.oracle.com/cd/E65465_01/html/E57770/kzuar.html#scrolltoc

root@t4-1:~# zonecfg -z openstack
Use 'create' to begin configuring a new zone.
zonecfg:openstack> create -t SYSsolaris-kz
zonecfg:openstack> select virtual-cpu
zonecfg:openstack:virtual-cpu> set ncpus=36
zonecfg:openstack:virtual-cpu> end
zonecfg:openstack> select capped-memory
zonecfg:openstack:capped-memory> set physical=40g
zonecfg:openstack:capped-memory> end
zonecfg:openstack> verify
zonecfg:openstack> exit
root@t4-1:~#

Now we can see installation process

root@t4-1: # zoneadm -z openstack install -a sol-11_3-openstack-sparc.uar -x install-size=60g

Progress being logged to /var/log/zones/zoneadm.20170302T200621Z.openstack.install
[Connected to zone 'openstack' console]
NOTICE: Entering OpenBoot.
NOTICE: Fetching Guest MD from HV.
NOTICE: Starting additional cpus.
NOTICE: Initializing LDC services.
NOTICE: Probing PCI devices.
NOTICE: Finished PCI probing.

SPARC T4-1, No Keyboard
Copyright (c) 1998, 2016, Oracle and/or its affiliates. All rights reserved.
OpenBoot 4.38.5, 40.0000 GB memory available, Serial #327404094.
Ethernet address 0:0:0:0:0:0, Host ID: 1383ca3e.

Boot device: disk1  File and args: - install aimanifest=/system/shared/ai.xml
SunOS Release 5.11 Version 11.3 64-bit
Copyright (c) 1983, 2015, Oracle and/or its affiliates. All rights reserved.

### I saw some network warnings

Mar  2 20:06:44 auditd[15]: adt_get_local_address couldn't get 26 addrlist socket: Address family not supported by protocol family: Bad file number.
Mar  2 20:06:44 auditd[15]: adt_get_local_address failed, no Audit IP address available, faking loopback for  and error Network is down.
Remounting root read/write
Probing for device nodes ...

Mar  2 20:06:45 auditd[29]: getaddrinfo() failed[node name or service name not known].
Mar  2 20:06:45 auditd[29]: adt_get_local_address couldn't get 26 addrlist socket: Address family not supported by protocol family: Bad file number.
Mar  2 20:06:45 auditd[29]: adt_get_local_address failed, no Audit IP address available, faking loopback for  and error Network is down.
Mar  2 20:06:46 auditd[44]: getaddrinfo() failed[node name or service name not known].
Mar  2 20:06:48 auditd[44]: adt_get_local_address failed, no Audit IP address available, faking loopback for  and error Network is down.

and then unpacking the UAR file .....

Preparing image for use
Done mounting image
Configuring devices.
Hostname: solaris
Using specified install manifest : /system/shared/ai.xml

solaris console login:
Automated Installation started
The progress of the Automated Installation will be output to the console
Detailed logging is in the logfile at /system/volatile/install_log
Press RETURN to get a login prompt at any time.

20:08:22    Install Log: /system/volatile/install_log
20:08:22    Using XML Manifest: /system/volatile/ai.xml
20:08:22    Using profile specification: /system/volatile/profile
20:08:22    Starting installation.
20:08:22    0% Preparing for Installation
20:08:22    100% manifest-parser completed.
20:08:22    100% None
20:08:22    0% Preparing for Installation
20:08:23    1% Preparing for Installation
20:08:23    2% Preparing for Installation
20:08:23    3% Preparing for Installation
20:08:23    4% Preparing for Installation
20:08:24    5% archive-1 completed.
20:08:24    6% install-env-configuration completed.
20:08:26    9% target-discovery completed.
20:08:29    Pre-validating manifest targets before actual target selection
20:08:29    Selected Disk(s) : c1d0
20:08:29    Pre-validation of manifest targets completed
20:08:29    Validating combined manifest and archive origin targets
20:08:29    Selected Disk(s) : c1d0
20:08:29    9% target-selection completed.
20:08:29    10% ai-configuration completed.
..............
..............
..............
20:11:25    96% boot-archive completed.
20:11:26    Setting boot devices in firmware
20:11:26    Setting openprom boot-device
20:11:26    98% boot-configuration completed.
20:12:32    98% update-filesystem-owner-group completed.
20:12:32    98% transfer-ai-files completed.
20:12:32    98% cleanup-archive-install completed.
20:12:32    100% create-snapshot completed.
20:12:32    100% None
20:12:33    Automated Installation succeeded.
20:12:33    You may wish to reboot the system at this time.
Automated Installation finished successfully
The system can be rebooted now
Please refer to the /system/volatile/install_log file for details
After reboot it will be located at /var/log/install/install_log

[NOTICE: Zone halted]

[Connection to zone 'openstack' console closed]
        Done: Installation completed in 365.752 seconds.

Then I booted the zone and finished setup

root@t4-1-tvp540-i:/export/home/jack# zoneadm -z openstack boot
root@t4-1-tvp540-i:/export/home/jack# zlogin -C openstack
[Connected to zone 'openstack' console]
254/254
Configuring devices.
SC profile successfully generated as:
/etc/svc/profile/sysconfig/sysconfig-20170302-134943/sc_profile.xml

Exiting System Configuration Tool. Log is available at:
/system/volatile/sysconfig/sysconfig.log.320
Loading smf(5) service descriptions: 2/2
Hostname: openstack

openstack console login:

Once I logged in, I can verify that there're several OpenStack services installed

root@openstack:~$ svcs -a | grep openstack | wc -l
      58

I also realized that there were some disabled services

root@openstack:~$ svcs -a | grep openstack

disabled       21:49:35 svc:/application/openstack/heat/heat-db:default
disabled       21:49:35 svc:/application/openstack/heat/heat-api-cloudwatch:default
disabled       21:49:36 svc:/application/openstack/heat/heat-api-cfn:default
disabled       21:49:37 svc:/application/openstack/ironic/ironic-db:default
disabled       21:49:37 svc:/application/openstack/ironic/ironic-api:default
disabled       21:49:37 svc:/application/openstack/heat/heat-api:default
disabled       21:49:38 svc:/application/openstack/swift/swift-container-reconciler:default
disabled       21:49:38 svc:/application/openstack/cinder/cinder-backup:default
disabled       21:49:38 svc:/application/openstack/heat/heat-engine:default
disabled       21:49:38 svc:/application/openstack/ironic/ironic-conductor:default
disabled       21:49:39 svc:/application/openstack/neutron/neutron-l3-agent:default

I assumed that they are not required for a basic OpenStack deployment, which is the purpose of this post.

To get access to the OpenStack login page we need to go to: http://your_kernel_zoneip/horizon

The user and pass are admin and secrete, as is described in this doc

https://docs.oracle.com/cd/E65465_01/html/E57770/dashboard-access.html#scrolltoc




0 comentarios:

Post a Comment