3) Creating Solaris 8 Zone
Once we are logged in into our ldom, we need to configure our branded zones
bash-3.2# zonecfg -z s8-zone
s8-zone: No such zone configured
Use 'create' to begin configuring a new zone.
zonecfg:s8-zone> create -t SUNWsolaris8
zonecfg:s8-zone> set zonepath=/export/zones/sol8-zone
zonecfg:s8-zone> set autoboot=true
zonecfg:s8-zone> add net
zonecfg:s8-zone:net> set address=10.163.223.13
zonecfg:s8-zone:net> set physical=vnet0
zonecfg:s8-zone:net> end
zonecfg:s8-zone> verify
solaris8_support error: The Solaris 8 Containers right-to-use package
has not been installed
s8-zone: Brand-specific error
zonecfg:s8-zone>
From doc id 1019682.1
How to Setup Solaris 8 and 9 Containers (Branded Zones) in Solaris 10 (Doc ID 1019682.1)
Ensure the Solaris release on Global Zone is higher or equal to Solaris 10_U6, unless upgrade Solaris to a recent release
bash-3.2# more /etc/release
Oracle Solaris 10 8/11 s10s_u10wos_17b SPARC
Copyright (c) 1983, 2011, Oracle and/or its affiliates. All rights reserved.
Assembled 23 August 2011
Starting from Solaris 10_U6, SUNWs[89]brand[ru] packages are delivered with the DVD/ISO
For Solaris 10_U6 and higher, these packages must be used instead of the the packages included in downloaded or s8containers-bundle-solaris10-sparc.tar.gz or s9containers-bundle-solaris10- sparc.tar.gz
Package SUNWs[89]brand[ru] are part of subcluster SUNWCsolaris8 (SUNWCsolaris9)
These packages are included in MetaCluster : SUNWCXall or SUNWCall
For other MetaClusters, SUNWs[89]brand[ru] packages needs to be added to system
Please ensure that the packages are installed from DVD/ISO of the very same Solaris release as shown in /etc/system
Check existence of the SUNWs[89]brand[ru] packages
bash-3.2# pkginfo | egrep brand
system SUNWs8brandr Solaris 8 Containers: solaris8 brand support (Root)
system SUNWs8brandu Solaris 8 Containers: solaris8 brand support (Usr)
system SUNWs9brandr Solaris 9 Containers: solaris9 brand support (Root)
system SUNWs9brandu Solaris 9 Containers: solaris9 brand support (Usr)
For all Solaris releases, package SUNWs8brandk ( SUNWs9brandk) needs to be added
Package SUNWs8brandk ( SUNWs9brandk) is part of downloaded
s9containers-bundle-solaris10-sparc.tar.gz // older name-scheme for Solaris 9 bundle
p11842137_900_SOLARIS64.zip // new name-scheme for Solaris 9 bundle
s8containers-bundle-solaris10-sparc.tar.gz // older name-scheme for Solaris 8 bundle
p11702874_800_SOLARIS64.zip // new name-scheme for Solaris 8 bundle
i.e.
# pkgadd -d s9containers-bundle/1.0.1/Product SUNWs9brandk
# pkgadd -d s8containers-bundle/1.0.1/Product SUNWs8brandk
I was missing this part !!
3.1) Installing required patches
pkgadd -d s8containers-bundle/1.0.1/Product SUNWs8brandk
Processing package instance <SUNWs8brandk> from </opt/zone_patches/s8containers-bundle/1.0.1/Product>
Solaris 8 Containers: solaris8 brand support RTU(sparc) 11.10.0,REV=2008.09.20.18.50
Copyright 2008 Sun Microsystems, Inc. All rights reserved.
Use is subject to license terms.
Using </> as the package base directory.
## Processing package information.
## Processing system information.
8 package pathnames are already properly installed.
## Verifying package dependencies.
## Verifying disk space requirements.
## Checking for conflicts with packages already installed.
The following files are already installed on the system and are being
used by another package:
/usr/share/man/man5/solaris8.5
Do you want to install these conflicting files [y,n,?,q] y
## Checking for setuid/setgid programs.
Installing Solaris 8 Containers: solaris8 brand support RTU as <SUNWs8brandk>
## Installing part 1 of 1.
/usr/lib/brand/solaris8/files/patches/109147-44.zip
/usr/lib/brand/solaris8/files/patches/109221-01.zip
/usr/lib/brand/solaris8/files/patches/111023-03.zip
/usr/lib/brand/solaris8/files/patches/111431-01.zip
/usr/lib/brand/solaris8/files/patches/112050-04.zip
/usr/lib/brand/solaris8/files/patches/112605-04.zip
/usr/lib/brand/solaris8/files/patches/order
/usr/share/man/man5/solaris8.5
[ verifying class <none> ]
Installation of <SUNWs8brandk> was successful.
bash-3.2# pkginfo | egrep brand
system SUNWs8brandk Solaris 8 Containers: solaris8 brand support RTU <----- Package installed
system SUNWs8brandr Solaris 8 Containers: solaris8 brand support (Root)
system SUNWs8brandu Solaris 8 Containers: solaris8 brand support (Usr)
system SUNWs9brandr Solaris 9 Containers: solaris9 brand support (Root)
system SUNWs9brandu Solaris 9 Containers: solaris9 brand support (Usr)
3.2) Creating zone and importing flar file
bash-3.2#
bash-3.2# zonecfg -z s8-zone
s8-zone: No such zone configured
Use 'create' to begin configuring a new zone.
zonecfg:s8-zone> create -t SUNWsolaris8
zonecfg:s8-zone> set zonepath=/export/zones/sol8-zone
zonecfg:s8-zone> set autoboot=true
zonecfg:s8-zone> add net
zonecfg:s8-zone:net> set address=10.163.X.X
zonecfg:s8-zone:net> set physical=vnet0
zonecfg:s8-zone:net> end
zonecfg:s8-zone> verify
zonecfg:s8-zone> commit
zonecfg:s8-zone> exit
bash-3.2# zoneadm -z s8-zone install -u -a /opt/s8-zone.flar
/export/zones/sol8-zone must not be group readable.
/export/zones/sol8-zone must not be group executable.
/export/zones/sol8-zone must not be world readable.
/export/zones/sol8-zone must not be world executable.
could not verify zonepath /export/zones/sol8-zone because of the above errors.
zoneadm: zone s8-zone failed to verify
We are having a right issue over the zone directory
bash-3.2# chmod 700 sol8-zone/
bash-3.2# zoneadm -z s8-zone install -u -a /opt/s8-zone.flar
Log File: /var/tmp/s8-zone.install.9485.log
Source: /opt/s8-zone.flar
Installing: This may take several minutes...
Postprocessing: This may take several minutes...
Result: Installation completed successfully.
Log File: /export/zones/sol8-zone/root/var/log/s8-zone.install.9485.log
bash-3.2#
From doc id 1019682.1
Zone Migration and Initial Boot (similar for Solaris 9 branded zones)
During the process of installing the solaris8 branded zone, a physical-to-virtual conversion is automatically performed.
When a solaris8 branded zone is migrated to a new host, this process must be repeated to ensure that the zone is optimized to run on the new host.
The first time that the zone attempts to boot on the new host it will detect whether the s8_p2v conversion command has been run.
The zone will not boot if the command has not been run again.
/usr/lib/brand/solaris8/s8_p2v is part of package SUNWs8brandu
bash-3.2# /usr/lib/brand/solaris8/s8_p2v s8-zone
[Wed Aug 19 13:12:53 PDT 2015] S20_apply_patches: Unpacking patch: 109147-44
[Wed Aug 19 13:12:53 PDT 2015] S20_apply_patches: Installing patch: 109147-44
Checking installed patches...
Patch 109147-44 has already been applied.
See patchadd(1M) for instructions.
Patchadd is terminating.
[Wed Aug 19 13:12:54 PDT 2015] S20_apply_patches: Unpacking patch: 111023-03
[Wed Aug 19 13:12:54 PDT 2015] S20_apply_patches: Installing patch: 111023-03
Checking installed patches...
Patch 111023-03 has already been applied.
See patchadd(1M) for instructions.
Patchadd is terminating.
[Wed Aug 19 13:12:54 PDT 2015] S20_apply_patches: Unpacking patch: 111431-01
[Wed Aug 19 13:12:54 PDT 2015] S20_apply_patches: Installing patch: 111431-01
Checking installed patches...
This patch is obsoleted by patch 108993-11 which has already
been applied to this system.
Patchadd is terminating.
[Wed Aug 19 13:12:55 PDT 2015] S20_apply_patches: Unpacking patch: 112605-04
[Wed Aug 19 13:12:55 PDT 2015] S20_apply_patches: Installing patch: 112605-04
Checking installed patches...
Patch 112605-04 has already been applied.
See patchadd(1M) for instructions.
Patchadd is terminating.
[Wed Aug 19 13:12:56 PDT 2015] S20_apply_patches: Unpacking patch: 112050-04
[Wed Aug 19 13:12:56 PDT 2015] S20_apply_patches: Installing patch: 112050-04
Checking installed patches...
Patch 112050-04 has already been applied.
See patchadd(1M) for instructions.
Patchadd is terminating.
[Wed Aug 19 13:12:56 PDT 2015] S20_apply_patches: Unpacking patch: 109221-01
[Wed Aug 19 13:12:56 PDT 2015] S20_apply_patches: Installing patch: 109221-01
Checking installed patches...
This patch is obsoleted by patch 109318-30 which has already
been applied to this system.
Patchadd is terminating.
3.3) Starting zone
bash-3.2# zoneadm -z s8-zone boot
bash-3.2#
bash-3.2# zoneadm list
global
s8-zone
bash-3.2#
After making the initial setup of the zone ,we can login and verify the status of the same
bash-3.2# zlogin -C s8-zone
[Connected to zone 's8-zone' console]
bash-2.03# more /etc/release
Solaris 8 HW 12/02 s28s_hw1wos_06a SPARC
Copyright 2002 Sun Microsystems, Inc. All Rights Reserved.
Assembled 12 December 2002
bash-2.03#
https://community.oracle.com/docs/DOC-920418
CONTENT
1) Getting the flar files from the Physical Systems (Part 2)
2) Creating LDOM (Part 3)
3) Creating Solaris 8 zone (Part 4)
4) Creating Solaris 9 zone (Part 5)
5) Moving between Primary/Guest Domain and Zones (Part 6)
Once we are logged in into our ldom, we need to configure our branded zones
bash-3.2# zonecfg -z s8-zone
s8-zone: No such zone configured
Use 'create' to begin configuring a new zone.
zonecfg:s8-zone> create -t SUNWsolaris8
zonecfg:s8-zone> set zonepath=/export/zones/sol8-zone
zonecfg:s8-zone> set autoboot=true
zonecfg:s8-zone> add net
zonecfg:s8-zone:net> set address=10.163.223.13
zonecfg:s8-zone:net> set physical=vnet0
zonecfg:s8-zone:net> end
zonecfg:s8-zone> verify
solaris8_support error: The Solaris 8 Containers right-to-use package
has not been installed
s8-zone: Brand-specific error
zonecfg:s8-zone>
From doc id 1019682.1
How to Setup Solaris 8 and 9 Containers (Branded Zones) in Solaris 10 (Doc ID 1019682.1)
Ensure the Solaris release on Global Zone is higher or equal to Solaris 10_U6, unless upgrade Solaris to a recent release
bash-3.2# more /etc/release
Oracle Solaris 10 8/11 s10s_u10wos_17b SPARC
Copyright (c) 1983, 2011, Oracle and/or its affiliates. All rights reserved.
Assembled 23 August 2011
Starting from Solaris 10_U6, SUNWs[89]brand[ru] packages are delivered with the DVD/ISO
For Solaris 10_U6 and higher, these packages must be used instead of the the packages included in downloaded or s8containers-bundle-solaris10-sparc.tar.gz or s9containers-bundle-solaris10- sparc.tar.gz
Package SUNWs[89]brand[ru] are part of subcluster SUNWCsolaris8 (SUNWCsolaris9)
These packages are included in MetaCluster : SUNWCXall or SUNWCall
For other MetaClusters, SUNWs[89]brand[ru] packages needs to be added to system
Please ensure that the packages are installed from DVD/ISO of the very same Solaris release as shown in /etc/system
Check existence of the SUNWs[89]brand[ru] packages
bash-3.2# pkginfo | egrep brand
system SUNWs8brandr Solaris 8 Containers: solaris8 brand support (Root)
system SUNWs8brandu Solaris 8 Containers: solaris8 brand support (Usr)
system SUNWs9brandr Solaris 9 Containers: solaris9 brand support (Root)
system SUNWs9brandu Solaris 9 Containers: solaris9 brand support (Usr)
For all Solaris releases, package SUNWs8brandk ( SUNWs9brandk) needs to be added
Package SUNWs8brandk ( SUNWs9brandk) is part of downloaded
s9containers-bundle-solaris10-sparc.tar.gz // older name-scheme for Solaris 9 bundle
p11842137_900_SOLARIS64.zip // new name-scheme for Solaris 9 bundle
s8containers-bundle-solaris10-sparc.tar.gz // older name-scheme for Solaris 8 bundle
p11702874_800_SOLARIS64.zip // new name-scheme for Solaris 8 bundle
i.e.
# pkgadd -d s9containers-bundle/1.0.1/Product SUNWs9brandk
# pkgadd -d s8containers-bundle/1.0.1/Product SUNWs8brandk
I was missing this part !!
3.1) Installing required patches
pkgadd -d s8containers-bundle/1.0.1/Product SUNWs8brandk
Processing package instance <SUNWs8brandk> from </opt/zone_patches/s8containers-bundle/1.0.1/Product>
Solaris 8 Containers: solaris8 brand support RTU(sparc) 11.10.0,REV=2008.09.20.18.50
Copyright 2008 Sun Microsystems, Inc. All rights reserved.
Use is subject to license terms.
Using </> as the package base directory.
## Processing package information.
## Processing system information.
8 package pathnames are already properly installed.
## Verifying package dependencies.
## Verifying disk space requirements.
## Checking for conflicts with packages already installed.
The following files are already installed on the system and are being
used by another package:
/usr/share/man/man5/solaris8.5
Do you want to install these conflicting files [y,n,?,q] y
## Checking for setuid/setgid programs.
Installing Solaris 8 Containers: solaris8 brand support RTU as <SUNWs8brandk>
## Installing part 1 of 1.
/usr/lib/brand/solaris8/files/patches/109147-44.zip
/usr/lib/brand/solaris8/files/patches/109221-01.zip
/usr/lib/brand/solaris8/files/patches/111023-03.zip
/usr/lib/brand/solaris8/files/patches/111431-01.zip
/usr/lib/brand/solaris8/files/patches/112050-04.zip
/usr/lib/brand/solaris8/files/patches/112605-04.zip
/usr/lib/brand/solaris8/files/patches/order
/usr/share/man/man5/solaris8.5
[ verifying class <none> ]
Installation of <SUNWs8brandk> was successful.
bash-3.2# pkginfo | egrep brand
system SUNWs8brandk Solaris 8 Containers: solaris8 brand support RTU <----- Package installed
system SUNWs8brandr Solaris 8 Containers: solaris8 brand support (Root)
system SUNWs8brandu Solaris 8 Containers: solaris8 brand support (Usr)
system SUNWs9brandr Solaris 9 Containers: solaris9 brand support (Root)
system SUNWs9brandu Solaris 9 Containers: solaris9 brand support (Usr)
3.2) Creating zone and importing flar file
bash-3.2#
bash-3.2# zonecfg -z s8-zone
s8-zone: No such zone configured
Use 'create' to begin configuring a new zone.
zonecfg:s8-zone> create -t SUNWsolaris8
zonecfg:s8-zone> set zonepath=/export/zones/sol8-zone
zonecfg:s8-zone> set autoboot=true
zonecfg:s8-zone> add net
zonecfg:s8-zone:net> set address=10.163.X.X
zonecfg:s8-zone:net> set physical=vnet0
zonecfg:s8-zone:net> end
zonecfg:s8-zone> verify
zonecfg:s8-zone> commit
zonecfg:s8-zone> exit
bash-3.2# zoneadm -z s8-zone install -u -a /opt/s8-zone.flar
/export/zones/sol8-zone must not be group readable.
/export/zones/sol8-zone must not be group executable.
/export/zones/sol8-zone must not be world readable.
/export/zones/sol8-zone must not be world executable.
could not verify zonepath /export/zones/sol8-zone because of the above errors.
zoneadm: zone s8-zone failed to verify
We are having a right issue over the zone directory
bash-3.2# chmod 700 sol8-zone/
bash-3.2# zoneadm -z s8-zone install -u -a /opt/s8-zone.flar
Log File: /var/tmp/s8-zone.install.9485.log
Source: /opt/s8-zone.flar
Installing: This may take several minutes...
Postprocessing: This may take several minutes...
Result: Installation completed successfully.
Log File: /export/zones/sol8-zone/root/var/log/s8-zone.install.9485.log
bash-3.2#
From doc id 1019682.1
Zone Migration and Initial Boot (similar for Solaris 9 branded zones)
During the process of installing the solaris8 branded zone, a physical-to-virtual conversion is automatically performed.
When a solaris8 branded zone is migrated to a new host, this process must be repeated to ensure that the zone is optimized to run on the new host.
The first time that the zone attempts to boot on the new host it will detect whether the s8_p2v conversion command has been run.
The zone will not boot if the command has not been run again.
/usr/lib/brand/solaris8/s8_p2v is part of package SUNWs8brandu
bash-3.2# /usr/lib/brand/solaris8/s8_p2v s8-zone
[Wed Aug 19 13:12:53 PDT 2015] S20_apply_patches: Unpacking patch: 109147-44
[Wed Aug 19 13:12:53 PDT 2015] S20_apply_patches: Installing patch: 109147-44
Checking installed patches...
Patch 109147-44 has already been applied.
See patchadd(1M) for instructions.
Patchadd is terminating.
[Wed Aug 19 13:12:54 PDT 2015] S20_apply_patches: Unpacking patch: 111023-03
[Wed Aug 19 13:12:54 PDT 2015] S20_apply_patches: Installing patch: 111023-03
Checking installed patches...
Patch 111023-03 has already been applied.
See patchadd(1M) for instructions.
Patchadd is terminating.
[Wed Aug 19 13:12:54 PDT 2015] S20_apply_patches: Unpacking patch: 111431-01
[Wed Aug 19 13:12:54 PDT 2015] S20_apply_patches: Installing patch: 111431-01
Checking installed patches...
This patch is obsoleted by patch 108993-11 which has already
been applied to this system.
Patchadd is terminating.
[Wed Aug 19 13:12:55 PDT 2015] S20_apply_patches: Unpacking patch: 112605-04
[Wed Aug 19 13:12:55 PDT 2015] S20_apply_patches: Installing patch: 112605-04
Checking installed patches...
Patch 112605-04 has already been applied.
See patchadd(1M) for instructions.
Patchadd is terminating.
[Wed Aug 19 13:12:56 PDT 2015] S20_apply_patches: Unpacking patch: 112050-04
[Wed Aug 19 13:12:56 PDT 2015] S20_apply_patches: Installing patch: 112050-04
Checking installed patches...
Patch 112050-04 has already been applied.
See patchadd(1M) for instructions.
Patchadd is terminating.
[Wed Aug 19 13:12:56 PDT 2015] S20_apply_patches: Unpacking patch: 109221-01
[Wed Aug 19 13:12:56 PDT 2015] S20_apply_patches: Installing patch: 109221-01
Checking installed patches...
This patch is obsoleted by patch 109318-30 which has already
been applied to this system.
Patchadd is terminating.
3.3) Starting zone
bash-3.2# zoneadm -z s8-zone boot
bash-3.2#
bash-3.2# zoneadm list
global
s8-zone
bash-3.2#
After making the initial setup of the zone ,we can login and verify the status of the same
bash-3.2# zlogin -C s8-zone
[Connected to zone 's8-zone' console]
bash-2.03# more /etc/release
Solaris 8 HW 12/02 s28s_hw1wos_06a SPARC
Copyright 2002 Sun Microsystems, Inc. All Rights Reserved.
Assembled 12 December 2002
bash-2.03#
https://community.oracle.com/docs/DOC-920418
CONTENT
1) Getting the flar files from the Physical Systems (Part 2)
2) Creating LDOM (Part 3)
3) Creating Solaris 8 zone (Part 4)
4) Creating Solaris 9 zone (Part 5)
5) Moving between Primary/Guest Domain and Zones (Part 6)
0 comentarios:
Post a Comment